Highcharts 中文社区

查看: 605|回复: 1

[提问帖] boost-canvas.js兼容性问题

[复制链接]
  • TA的每日心情
    郁闷
    2018-5-11 09:14
  • 签到天数: 21 天

    [LV.4]偶尔看看III

    13

    主题

    25

    帖子

    227

    积分

    HC 熟手

    Rank: 2

    积分
    227
    发表于 2019-10-18 15:26:50 | 显示全部楼层 |阅读模式
    我在ie8上测试boost-canvas.js版本是v7.2.0 (2019-09-03),控制台报错“SCRIPT438: 对象不支持“getContext”属性或方法 ”,于是尝试将boost模块注释,图表数据无法显示,10分钟数据可以正常显示(数据量2400),一小时数据无法显示(数据量14400),IE浏览版本为IE8,highstock版本v7.2.0

  • TA的每日心情
    无聊
    2019-8-12 09:47
  • 签到天数: 263 天

    [LV.8]以坛为家I

    30

    主题

    949

    帖子

    4574

    积分

    版主

    Rank: 7Rank: 7Rank: 7

    积分
    4574

    最佳新人活跃会员

    QQ
    发表于 2019-10-18 17:09:47 | 显示全部楼层
    boost-canvas.js 是基于 canvas 的, IE8 不支持 Canvas,所以不兼容是正常的。

    14400 数据量  Highstock (构造函数是 stockChart)是完全支持的了的。
    Highcharts 中文网论坛管理团队

    我们提供:商业授权技术支持图表定制VIP服务 等相关支持服务
    在线客服:2133220776(QQ,非技术,工作日 10:00 ~ 17:00)
    新浪微博:http://weibo.com/highcharts
    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    关闭

    站长推荐上一条 /1 下一条

    快速回复 返回顶部 返回列表